Saturday, March 5, 2011

Saturday project- dual boot stock+CM7 - ongoing

one of the best things about the NC- boots from sd card first. virtually non-brickable. I like rooted stock, and official Froyo with Flash is coming later this month, they say. I like CM7, I like Honeycomb. and I like the idea of being able to boot into one or the other from sd when I want to.

I'll keep on the lookout for CM7 bootable from sd, but I'm gonna give it a go on my own too. this is going to take a while- semester projects are coming due soon, but my allotted "geek-out" time will be spent working on this.

edit: totally changed my mind on bootable CM7 sd once I looked over the dual boot instructions again.

first step:
not sure if I'll reflash a recovery of rooted stock or start from scratch and use titanium backup.
(the only way to use Titanium Backup with rooted stock is to move the apk's to /system/app and reboot. fix permissions in CWR first and mount in root explorer R/W (toggle button at the top). root explorer is certainly worth the ~$4.19)

I could have saved myself some panic by going back to mounts and storage and unmounting the sd card before rebooting. rebooted into CWR to see ahead of time what needed to be done and how to get there. tried to reboot to put the .zip on the card and go through the actual process. I took the card out during the reboot so it wouldn't keep rebooting into CWR and had a "dead" NC for a few minutes after putting the card back in. now I'm going through the stuck on n screen reboots. 8 failed boots gets me to the install, but it gets stuck on n afterwards.. need a recovery sd and start over.

well frikin duh.. wish it didn't take me all day to come across this... (I spent far too much time trying to make the Froyo sd and get all that to work)
copied 1.01 full install (my original version) to the sd, used CWR to install from .zip on sd and hooray! back to stock NookColor. back to recovery sd on hand.

auto-nooter next:
a word on auto-nooter: the instructions say that the NC will boot when plugged into the computer and will reboot when it is done. when I plug in my NC, nothing happens.. for a while.. after about 5 minutes, then it rebooted and all was well. have patience, or a repeat will be necessary.

I miss CM7 and widgets. but it's fast again, everything works again, internal and sd storage are available. I'll see how dual boot goes. that could be better. at least now I have a recovery sd ready and the auto-nooter sd, and know to hold onto them.

dual boot is where it's at. left stock where it was and CM7 is on secondary (power+n to boot in)

got gapps installed.
(I don't suggest flashing the from CRW- made Market go away in stock and I had to re-nooter.. and the Market still didn't work in CM7, so it was a waste of time altogether)

fix the framework.jar file for CM7.. I assume through the OP's instructions that I needed to mount and push to correct partition, 1o9 in my case, which worked. (though another post for pushing something else says 0p9)
is it possible to find the AndroidID on the stock side and mirror for other ROMs?

all set up, most apps work (to be expected), tethering from the G2 works on both sides. dual boot is better than running from sd, but still no "mountable" access to internal storage from CM7, and now to figure out how to make a CM7 ROM into a version that can be flashed to the correct boot partition. (I like phiremod, and there's bound to be newer ROMs that come out, and I'd rather have actual versions than nightlies)

can I just make a new zip with phiremod's ramdisk and other files with the same u-boot files from the verified dual boot file? gonna try this after confirmation:
make a .zip file with these files from the OP for CM7 dual-boot file:
and add from phiremod's ROM:
        system folder
        META-INF folder

and I assume I need to remove dual and go through the process again to get this going, as from what I understand, phiremod v4 uses ext3 instead of ext4.

hhmm... this is going to take some more fiddling.. removed dual-boot, did the prep again, loaded my zip, boot loop on stock rooted no matter if just power or power+n. doing a complete restore again. the kernel from phiremod is OC, and I did not include the, as the post says it is ext3. so we'll try a zip with the CM7 kernel and if that doesn't work, include the as well. no reply on the dual-boot thread yet. learning process!

someone was kind enough to post this response:
maybe take a look at that next Saturday.

HA! CM7 nightly12 has access to internal storage. dual boot zip made. throwing this on now. phiremod is now unnecessary. (but I'll still tinker with building the dual boot ROM)
not so much... perhaps due to being dual-boot? I was also under the impress that the framework patch/hack was included. the research continues.. I need to get some homework done.

for reference:

awesome: completely powered down, NC turns on by itself randomly, even before I started messing with it, known comment. since dual-boot, stays off as it should. no more random start ups.

NC's been getting all the attention lately. next Saturday: G2 gets an update (too).

Thursday, March 3, 2011

wireless printer that doesn't

or, if I forget to cancel the job, will print two hours later and scare the shit out of me.

Canon Pixma MP495- fixed IP

connects to the Mac just fine. USB, wireless, great.

Win7 shared by the Mac spits out blank pages. Win7 and Ubuntu work perfectly through USB, but no matter the configuration on the printer's side for wireless, both OS see it, can get the status and whatnot, but errors when I go to print.

there was a time when it worked as it should.. but no matter how many times I uninstall and reset, I'm still left wanting to chuck it across the room, so I gave up trying to mess with it and kept with thinking about it.

I've come to the conclusion that this is one more reason to kick the Intel WiFi/WiMAX 6250 AGN in the face. seriously, it's not the printer. it has to be the wireless card if neither freshly-installed OS on this machine can print wirelessly.

other issues with this card:
-it has to be set to the lower encryption to talk to the Mac, which has to be wired directly to the router for them to play nice.
-the power management feature needs to be disabled for Ubuntu to use the card.
-the band has to be set to G only for it to get through the firewall on the router.
-it's also in a Dell machine, and it's been my ongoing experience that Dells and wireless don't always jive- I have too many things trying to claim the wireless card.

if I disable some stuff (all those wifi connection things, really, wtf), then I can expect sporadic connections. I'm in Maine for f's sake- no need for integrated WiMAX. that was a "bonus"- I gained WiMAX and forwent blu-ray on my laptop wish list in this purchase.

I'm gonna boot back into Win7 eventually, and when I do, I'm going to try the 128 encryption and see if makes an actual printed page. it used to work as an TCP/IP connection, sometimes..

why can't this be easy? this was supposed to be easy..