Wednesday, July 27, 2011

stupid Dell.

I'm never buying a Dell laptop again. this f'n thing won't connect with the Ubuntu drive again.. and I don't feel like messing with it anymore. the drive works with a frikin USB wireless dongle.. works with other computers with internal wireless. but not the internal wired or wireless with WiMax and all the other stupid connections this internal wireless card wants to have.

I shut down the laptop last night, and there was my mistake. wlan0 is now wlan1 for some reason.. it is active, the interfaces file I modified allows it to pick up the IP address and netmask that it's supposed to have.. but the wireless connection icon is gone, ya know, from up at the top next to the date and time.. completely gone. no clue wtf is happening.

tried setting boot order to Network first.. nope. this is really pissing me off.
gonna make the SD over again. back to using the live USB- nevermind.. that can't connect either.
     and now it does.. wtf is going on..

can't wait to sell this thing.

and good-bye Dell! replacement shall be ordered soon.

Monday, July 25, 2011

portable Ubuntu- part 2

my guess is this would work for Ubuntu and Chrome OS Linux, or almost anything with a big enough SD card and an OS that doesn't attach to specific hardware.

for testing purposes, I'm in Win7, using an 8GB micro sdhc class 6 card and VirtualBox. if this works right, this should be a fully functional Ubuntu (OS+settings+storage) that I can boot on any computer (able to boot from USB) and have my "system" with me where ever I go!
      if this is the case, I'll be getting a 16GB micro class 10 to use (I have a teenie adapter).

SUCCESS!! logged in with my username and pw, installed updates.. we are good to go! now that I know this method works, I'm going to try with the bigger card and partition it so my docs and stuff are accessible from any OS.
      until then, let's see if I can get this to work right on the laptop so it's not just sittin there lookin pretty.
            -nope. still can't get the damn internet going- loopback issue it seems. the search continues..
            -YEAY! I had changed the router from "auto" channel to a set channel when I was having
                    problems with that damn wireless mouse. as soon as I added this to the
                    /etc/network/interfaces and changed it back to auto, everything is fine (might change these
                    for when not using the laptop). posting from the laptop using Ubuntu SD!
                                  auto lo
                                  iface lo inet loopback

                                  auto wlan0
                                  iface wlan0 inet static

            -why can't I see the hard drives on the system? oh! now I can..
                              sudo mkdir /media/windows
                              sudo mount /dev/sda1 /media/windows -o force
                        - gonna see about adding a line to the shutdown script to unmount any media mounted
                                during that session- not able to normally unmount, and I would forget- I don't know
                                what would happen..

after an extended session, this runs pretty well. run on the laptop, shut down, boot up on the HP, works as it should! I'm starting to think it may just be fine as it is on this card- I'll just resize and make a new partition.
      a class 10 would be nice though- the red light on the big adapter is running at least once a minute and for writing, a class 6 is no match to a class 10.
      can't say how long this drive would last for as my regular system with all the writing and whatnot... and I never shut down.. but it is pretty cool to have, and more than likely will come in handy. time consuming, but not difficult to produce. keeping the 4GB Live SD too.
      next time I get around to it, gonna make a Chrome OS Linux on SD. I'll have a pocket full of OS's.
have to say, I love almost all Google products- Chrome is awesome. whatever I do in one place, I have at another.. what a concept!

modified from:
Install Live Ubuntu CD directly onto an SD card

Installation (by using a virtual machine)
1. Create a new virtual machine.

2. Don't add any virtual hard disk. (uncheck the Boot option and click Continue when it gives the warning)

3. Go into the machine Settings and activate USB support (USB menu), so you can install Ubuntu to your SD card by using an SD to USB adapter.

4. Boot up the virtual machine, navigate to the ISO- while Ubuntu boots up in the virtual machine, make sure your SD card is mounted from the Devices menu up top. When Ubuntu is ready (normal Live CD screen) choose Install.

5. Follow the installation instructions. (find something else to do- this takes a LONG TIME)

6. When the installation is complete, shutdown your virtual machine, insert the Ubuntu SD card into [a USB adapter and USB port] and power up. When the [computer's] splash screen comes up [enter boot order menu], and select the SD card as the boot drive. You will have to do this step at every boot up now if you want to start Ubuntu, but it allows you to keep [any other os] on the internal HD which can be booted with or without an SD card inserted.


something in windows tells the wireless and ethernet adapters not to work within Ubuntu- whether a live usb, live cd or actual install. it has always been a massive pain in my ass to get the settings right, and this time, I just don't even want to deal with it.

I cleaned out the laptop, reloaded Win7Pro, did all the updates and drivers and all that happy horseshit. I planned on running the Live USB so I could at least use it while I wait for it to be sold. I even packed up the HP and moved it aside until that happens...

stupid wireless and stupid ethernet.. I set the adapters back to how they were before the reinstall... and nada. I give up on messing with it any more.

a perfectly great laptop is just sitting here, not being used..

Sunday, July 24, 2011

HP fixed.

so I ran the Live CD and retrieved my files.. found an old, old XP Pro (no service pack) disk and key and through that re-partitioned and formatted the drive, and installed, ran all updates and installed imperative software.

I had remade the Live USB with 10.04LTS (wasn't really diggin 11.x), and installed that.. having issues with accessing all of my hard drive space.

gotta love Chrome sync. I heart Google products and services.

I think I know what I did wrong- using the XP install disc, I made three partitions- one for XP, one for Ubuntu and the rest of the drive for shared stuff (movies, music, pics, etc). I couldn't figure out how to fix in in gparted.. so I guess I'll start over.

before I do that though, I'm going to break her down and do a thorough cleaning. the RW drive needs replacing, and all USB ports on back are 1.1, so perhaps get a PCI card as well.

edit: and even better, as a student of tech stuff, Microsoft loves me give me software to use for school. since the desktop is for school.. burned a Win7Pro 32-bit ISO and running now as a fresh install, with all partitions removed.

I don't need to get an actual Chromebook- I can just install Chrome OS Linux on a netbook.

portable Ubuntu

just for giggles, I took a 4GB class 6 microSD card, freshly formatted, and using a SD adapter and USB stick reader, followed instructions on the Ubuntu download page to make my very own "live" USB drive. Ubuntu itself only needs 2GB, so the rest of the space is for files and settings.

as long as I can boot from USB, I have a fully functional Ubuntu system on any computer- hanging from my keychain. how cool is that..

edit: duh.. and I am now using this card to use Ubuntu on the HP to retrieve all my files and go through with the reformatting. taking a wicked long time to boot though. this thing is so old, I may have to try different USB ports to find the fastest one.. I remember this problem before.
-nope.. had to pull out the live CD I made last year. oh well, I know the live stick works for more current systems.
-aahh.. the problem was the USB adapter stick thingy.. one of them wouldn't read anything, while the other one does. stupid old HP..

Friday, July 22, 2011

netbook dreams

Acer Aspire One AO722-BZ454 11.6-Inch HD Netbook
the size of a spiral bound notebook.. 2 lbs lighter than my laptop.. almost full size keyboard, less annoying screen size, and Win7HP preinstalled w/2GB. makes sense.

and as to why I'm getting a new one- can't find an older model or used/refurb for much less than a new, better model.

I loved my little Dell 300x.. or x300.. whatever it was.. I loved it.

I've been wanting a netbook for a while. and though I have a *very* decent 14" laptop, it is too big, heavy and hot to lug around, take to the dog park, use on the couch or in bed without a lap desk thingy.. toting this thing around on campus is a wicked pain in the ass. I'm pretty much stuck at the desk with it, and that's not where I feel like being stuck. I want to be UN-stuck, as a matter of fact.

almost everything I do is online or on a thumb drive.

after I get done with this week's homework, I'm gonna begin working on the HP. start her up and make sure I have all my files.. complete tear down, clean and back together.. and then follow my previously posted handy guide to a dual-boot set up.

if I'm going to have a desk set-up, I might as well be using the desktop. if I need to be ultra-portable, I might as well sell the laptop and get a netbook and any minor upgrades the HP needs. (and gain some desk space!)
      I love, love, love my laptop. don't get me wrong.. I would much rather turn the HP into a file server or give it away or whatever and keep the laptop *and* get a netbook and of course still have the mini.. but I can't justify a laptop and a netbook...

I bought this thing for $899 only a year ago- they are now a mere $579.. frik!

Wednesday, July 20, 2011

Ubuntu woes

this is seriously pissing me off.

a wired or wireless mouse does not work well- clicks I didn't make, selections I didn't make, not clicking, clicking too much, selections not sticking and then the whole text disappears, like I erased it, freaking me the f out.. wanna paste, better do it on a new line and merge, or else anything to the left of where I want to paste is selected and pasted over.

this just doesn't make sense.

the wired keyboard acts much of the same way. skipping keystrokes, adding in keystrokes, delay in keystrokes appearing.

the thing that gets me the most is it is worse in a web setting, you know.. where I *always* am.. like BlackBoard where I write and submit homework.. writing blog posts (like this one.. grrr).. facebook.. google docs.. windows live..
      if I want to do any large amounts of copy and paste, I have to reach up on the desk and use the trackpad and keyboard on the laptop.

don't make me go work in windows.. cuz I will, dammit.

edit: it did get worse with the last kernel update a few days ago. gonna roll back and see if that makes a difference.
-nope. maybe it's firefox. installing Chrome.
-nope. not firefox. same thing in Chrome. my lawd, this is frustrating.

so Win7 downloaded and installed the drivers for the hub, keyboard and mouse.
omg.. I'm gonna scream soon.  anything web based is f'd, even in windows. even Word sucks- lag of input.

I just wanted to be more comfortable and productive..

this is a powered hub.. unplugged AC adapter and running from USB power. I don't care for that, as the hub is also a charging station for stuff and is constantly in use. I'll run with it for a little while and see how it goes. next test will involve moving to other USB ports on the hub, or trying a small, unpowered 2-port hub and leave the powered hub out of it.

having the hub AC unplugged made a difference in Win, and so far it is a lot better in Ubuntu as well.
-it's the AC power. ordering small hub and extension cable on amazon. no matter the configuration, pasting is still a bitch.
(life saver, delivered next day! -no selection issues, no pasting issues, everything working as it should! yeay!)

back with the wired mouse with the hub non-AC'd and nothing charging.. other than some minor selection issues, seems to be going well. Chrome is f'n fast! why wasn't I using this?

hhhrrrmmmm... seems the issue isn't that the hub is powered. AC plugged back in with only mouse and keyboard, nothing charging, works wonderfully. wheatevs.. mini hub and extension cable on the way.

Wednesday, July 13, 2011


I'm in!!

seems pretty cool so far. liking the instant integration on my G2, and instant upload will be awesome.

Wednesday, July 6, 2011


new keyboard arrived.. awesome.

powered USB hub arrived.. awesome.

all wires and chargers cleaned up and out of the way... awesome.

laptop screen farther away, lessening eye strain.. awesome.

I love it when shit works out the way I wanted.

now to find a way to slightly elevate the laptop to assist in cooling- unless anyone can help me adjust the fan settings in Ubuntu.

Saturday, July 2, 2011

the HP POS (ongoing)

POS stands for Piece of Shite, by the way.. this name was given after BSOD was remedied only by an improptu wipe-n-reload. couldn't get into Windows to back anything up. I lost *all* of Taryn's baby pics. pissed.

right now, it is not allowed to be connected the the internet. Time Warner shuts down our access due to spam or virus sending, and it only happens when this thing is connected. the last time it may have been the PS3, during all that Sony hack BS, it hasn't been reconnected either.

anyhoo.. this is what I'm working with. obviously, a compete internal cleaning and hard drive wipe needs to take place above all else.

HP Pavilion a1245c
AMD Athlon64 3700+ (2.19GHz)
ATI Graphics
Windows XP Media Center Edition
250GB hard drive
Litescribe DVD+- Writer (hasn't worked for two years)
DVD-ROM drive
Multi-card reader
3x USB 2.0, 4x USB 1.1
Firewire 1394

Mumma got her command central.. I have space for homework and the laptop now (and feel like I'm in the same room as everyone else), the desk with the Mac stays untouched. the HP sits on the bottom shelf of the Mac desk, and when I'm ready to play, I'll be able to easily drag the keyboard, mouse and monitor up onto my laptop area.

Ubuntu is happening... but will it be a dual boot? probably.. it can handle Win7. wouldn't it be great if we could run Windows from a Live CD?

also thinking about moving the 1TB drive to the HP via firewire to make it a true network drive- the other Windows machines have a hard time connecting- Ubuntu of course is fine, and the Mini can connect to any of them, and if it is connected to a Win box instead of the Mac, the PS3 will be able to access it without me fiddling, which Andy prefers I don't.
      just can't remember which way the format can go.. either format Win first for Mac and Win compat, or the other way around.. we will see. and we will see if I get ambitious to fix it..

edit: cool.. I ordered a 10-port USB hub for charging reasons, and where it is mounted will be perfect for switching from the laptop to HP for the keyboard and mouse. the monitor will be the only thing to haul up to the desk.
      I have a few old USB keyboards kicking around, but need something smaller to fit on the keyboard tray with the mouse.. problem solved with this:
      I was looking for a wireless keyboard, but with the issues I have with just a wireless mouse.. didn't want any more interference than I already had. *and* this keyboard has a number lock key- solves the problem with my numeric keypad that goes with the mouse. I'd hardly use it, but at least now I can!

edit: the number lock key on the keyboard does *not* allow the numberpad to work. but it is also a calculator.. still has a useful function.

Friday, July 1, 2011

Logitech v250 mouse and number pad

need drivers that don't lock up IRQ #16 after a while.

I'm stationed at the desk, I have arthritis.. using the touchpad on the laptop hurts after a while, and I remembered I had a wireless mouse stashed away. I plugged it in while I was in Win7, the drivers downloaded and the mouse worked great. without removing the dongle, I rebooted into Ubuntu. worked right away, even at the initial log-in screen.

I use TouchFreeze to disable the trackpad.. which only works for a little while, btw. the first time all this happened, I thought the problem was that I had the trackpad disabled and the mouse couldn't connect while in sleep mode- being an external device, of course it couldn't wake the laptop.

so I stopped using TouchFreeze- the mouse seems to work very well, until the screen saver comes on.. and if it gets to the point of screen blackness, I have to hard reboot, as the screen will not come back by either the trackpad or the mouse. same issue when I close the screen.. any sleep causes issues.

tried reconnecting the mouse, turned it off and on again.. no go.

the one and only time the screen did come back, disable IRQ #16 or something as an error, I was offered options for rebooting regarding X, and was rebooted into a command prompt. sudo reboot brought me back to normal.

I check the batteries in the mouse. from 2005. replaced, though the mouse worked fine, other than this issue. all Logitech drivers are for Windows.

this next test will involve changing the sleep settings.
      System- Preferences- Screen Saver- Power Management

a thread in Ubuntu Forums states that the numberpad will not work, as it acts as if the number lock is off, and since the laptop nor the numberpad have a number lock key...

I don't want to have to buy a new mouse and numberpad.. but I will if it really gets to that.

edit: closed the laptop while I dropped the girls off.. no issues!

edit: power went out a few times early this morning. thankfully the laptop was shut down for the night. power outages alway cause issues with the modem and router.. I couldn't snag a full wireless internet connection, and found it was the mouse causing the issue.
      if I want to use the mouse *and* have internet upon restart, I have to unplug the mouse, turn it off, restart, let the internet connect for a bit and then plug in the USB dongle, turn on the mouse and hit the connect buttons.
      might go out looking for a bluetooth mouse if this turns into a massive pain.

edit: reading some more, some people have changed the channel of their wireless router. the two sets of wireless HIDs are now working better, and the internet is faster.

now to figure out the fucking LAG in Ubuntu while typing on the laptop keyboard.